Great Circle Associates Majordomo-Users
(July 1996)
 

Indexed By Date: [Previous] [Next] Indexed By Thread: [Previous] [Next]

Subject: Re: code errors?
From: Jason L Tibbitts III <tibbs @ hpc . uh . edu>
Date: 03 Jul 1996 23:38:48 -0500
To: hjass @ smartt . com
Cc: majordomo-users @ GreatCircle . COM
In-reply-to: "Haralds Jass"'s message of Wed, 3 Jul 1996 19:16:16 -0800
References: <199607040216.TAA11975@ktk1.SMARTT.COM>

>>>>> "HJ" == "Haralds Jass" <hjass@smartt.com> writes:

HJ> I have installed Majordomo 1.93 recently, and is it really true that
HJ> all of its perl files have errors?

No, they don't.  Perhaps a couple of warnings, though I've never seen any.

HJ> >> shlock.pl
HJ> ./shlock.pl: package: command not found 
[...]

Something is seriously wrong here.  It looks like sh or csh is trying to
run the files instead of perl.  What does the first line of each script
look like (does it point to a valid perl executable)?  Are you certain that
your mail transfer agent (you don't say which one you're running) doesn't
use sh to spawn command aliases?  Does your OS (you don't say which one
you're running) support the #! syntax in scripts?

I'd really check your MTA configuration.  Something is seriously wrong;
most of these these aren't even perl errors, though some are (and they
don't appear on a normal installation).
-- 
      Jason L. Tibbitts III - tibbs@uh.edu - 713/743-8684 - 221SR1
System Manager:  University of Houston High Performance Computing Center
                1994 PC800 "Kuroneko"      DoD# 1723


Follow-Ups:
References:
Indexed By Date Previous: code errors?
From: "Haralds Jass" <hjass@smartt.com>
Next: Re: code errors?
From: "Haralds Jass" <hjass@smartt.com>
Indexed By Thread Previous: code errors?
From: "Haralds Jass" <hjass@smartt.com>
Next: Re: code errors?
From: bill@celestial.com (Bill Campbell)

Google
 
Search Internet Search www.greatcircle.com