Great Circle Associates Majordomo-Users
(September 1999)
 

Indexed By Date: [Previous] [Next] Indexed By Thread: [Previous] [Next]

Subject: Re: unknown mailer error 1
From: "Wm. Josiah Erikson" <josiah @ bork . hampshire . edu>
Date: Wed, 01 Sep 1999 02:12:30 -0400
To: majordomo-users @ greatcircle . com
References: <37CB7306.FBC02F11@aiko.com>

Do you have a line in your /etc/aliases file that looks JUST like this:

majordomo:        "|/usr/local/bin/majordomo-1.94.4/wrapper majordomo"

And does /usr/local/bin/majordomo-1.94.4/wrapper exist? Don't you have to
install majordomo into some directory other than the one you unpacked the
installation files into, and don't the installation files automatically
unpack into a directory called majordomo-1.94.4 ?

    I had some similar issues the other day, and I finally got it figured
out. Nobody answered my questions, so I thought I'd answer yours, if I
could. Not that I really know what I"m talking about, but majordomo IS
working for me now. Have you gotten it working yet?
    Good luck,
    Josiah



Roscoe Primrose wrote:

> Having a real problem with getting 1.94.4 up and running...  Tried with
> perl 5.003.?? and 5.005.02, same symptoms.  Sendmail 8.9.1, kernel
> version 2.0.33
>
> Error message returned is:
>
>    ----- The following addresses had permanent fatal errors -----
> "|/usr/local/bin/majordomo-1.94.4/wrapper majordomo"
>     (expanded from: majordomo)
>
>    ----- Transcript of session follows -----
> deliver: delivery error on host ripple.
> Delivery to these addresses failed:
>         |/usr/local/bin/majordomo-1.94.4/wrapper majordomo
> Reason(s) for failure:
>         "|/usr/local/bin/majordomo-1.94.4/wrapper majordomo":
>                 Address not valid from command line
> 554 "|/usr/local/bin/majordomo-1.94.4/wrapper majordomo"... unknown
> mailer error 1
>
> I've checked the permissions, been through the FAQ, even been through
> the list archives since Jan...  Yes, I've got Mprog in my
> sendmail.cf...  I've changed the name of wrapper (so it shouldn't have
> worked) and the error didn't change, which makes me suspect a sendmail
> problem, but I've about tried all the options I can think of,
> downloading 8.9.3 now..
>
> Any other ideas???
>
> Peace
> --
> Roscoe Primrose
> -- mailto:roscoe@aiko.com -- http://www.aiko.com/roscoe --
>
> "Once in a while you get shown the light
> In the strangest of places if you look at it right." Robert Hunter


Indexed By Date Previous:
From: (nil)
Next: Re: Sendmail configuration
From: Gennaro Esposito <esposito@marscenter.it>
Indexed By Thread Previous:
From: (nil)
Next: Re: unknown mailer error 1
From: "Adam H. Kerman" <ahk@chinet.com>

Google
 
Search Internet Search www.greatcircle.com