Great Circle Associates Majordomo-Users
(August 2000)
 

Indexed By Date: [Previous] [Next] Indexed By Thread: [Previous] [Next]

Subject: Re: strange problems with permissions...
From: Dan Liston <dliston @ netscape . com>
Organization: iPlanet E-Commerce Solutions, A Sun Netscape Alliance
Date: Fri, 25 Aug 2000 11:59:37 -0500
To: gregm @ smcmetal . com
Cc: majordomo-users @ GreatCircle . COM
References: <000301c00de9$cf0dc0e0$6201010a@smcmetal.com>

Check your sendmail /var/log/maillog, and your /usr/test/majordomo-1.94.5/Log
files.  If your problem is a permissions issue, and you do not have "users"
local to that machine, disable sendmail security by uncommenting
#O DontBlameSendmail=safe
in the sendmail.cf file.

If you do have users on the same machine as sendmail and majordomo, Check the
group write bit on every directory in the tree leading to your lists directory
and turn it off with chmod g-w directoryname and chmod -R g-w /path/to/majordomo

Dan Liston

Greg Muehl wrote:
> 
> Did anyone ever get this (appended problem) fixed? I have the exact same
> problem on my Slackware Linux 7 machine with sendmail 8.9, however I didn't
> mess up the permissions. I tried chmod 644 to some of the files but it
> didn't help. Is there a list of what files need to be changed? Here is what
> I see in /var/log/messages when I try to post to the list:
> 
> Aug 24 11:27:29 ns1 sendmail[5734]: LAA05734:
> to="|/usr/test/majordomo-1.94.5/wr
> apper resend -l bigsnow bigsnow-list", delay=00:00:01, xdelay=00:00:01,
> mailer=p
> rog, stat=Sent
> 
> But, the people on the list dont receive anything. I have reinstalled twice
> to no avail.
> 
> Any help would be appreciated
> 
> -----Original Message-----
> From: majordomo-users-owner@GreatCircle.COM
> [mailto:majordomo-users-owner@GreatCircle.COM]On Behalf Of Juan Luis
> Baptiste M.
> Sent: Wednesday, August 23, 2000 3:35 PM
> To: majordomo-users@GreatCircle.COM
> Subject: strange problems with permissions...
> 
> Hi,
> 
> I manage a majordomo list and someone by error misconfigured the
> permissions on the files of majordomo. I tried to fix all the mess with
> no success. All files are owned by majordomo, wrapper owned by root and
> SUID on, lists directory and all files in it with perms 0664 but if I
> send any mail to the list it never get back top the users! there's no
> mail to the list owner or root indicating that there's an error ,
> there's nothing on majordomo's Log. The strange thing is that users can
> subscribe to the list and send commands to it but not to the mailing
> list.
> 
> Any suggestions???
> 
> Thanks,
> 
> Juan Luis Baptiste M.



Follow-Ups:
References:
Indexed By Date Previous: Re: aliases/loop broken
From: Dan Liston <dliston@netscape.com>
Next: Re: strange problems with permissions...
From: Dan Liston <dliston@netscape.com>
Indexed By Thread Previous: RE: strange problems with permissions...
From: "Greg Muehl" <gregm@smcmetal.com>
Next: RE: strange problems with permissions...
From: "Greg Muehl" <gregm@smcmetal.com>

Google
 
Search Internet Search www.greatcircle.com